3 Add domains for SSL

Good Day,
I’ve been searching the internet since yesterday, so I know this isn’t the first time the question has been asked, but I can’t come up with a solution.

I have 3 domains:
hytale-forum.net —> var/www/html
hytale-wiki.net —> var/www/html/wikipedia
hytale-market.net —> var/www/html/marktplatz

I want to redirect these 3 domains to one server.
This is also no problem.

The problem is registering the domains in LetsEncrypt for additional SSL certificates for one server in different directories.
hytale-wiki.net
hytale-market . net

Registration for the domain “hytale-forum.net
has worked without problems, only adding newer domains to different directories is currently a problem

My latest attempt to generate the certificates:
certbot-auto certonlyly --webroot --cert-name hytale-forum.net -w /var/www/html/wikipedia -d hytale-wiki.net -w /var/www/html/marketplace -d hytale-market.net

I hope I could get my problem across in an understandable way.

1 Like

–webroot-path WEBROOT_PATH, -w WEBROOT_PATH
public_html / webroot path. This can be specified
multiple times to handle different domains; each
domain will have the webroot path that preceded it
.
For instance: -w /var/www/example -d example.com -d www.example.com -w /var/www/thing -d thing.net -d m.thing.net (default: Ask)

Using that information, we can form the command that should do want you want:

certbot certonly --cert-name hytale-forum.net --webroot \
-w /var/www/html -d hytale-forum.net \
-w /var/www/html/wikipedia -d hytale-wiki.net \
-w /var/www/html/marktplatz -d hytale-market.net \
--dry-run

That’s similar to the command you came up with.

However, that might not be your actual problem.

Two of your domains - hytale-wiki.net and hytale-market.net - point to a Namecheap URL Forwarding service.

$ curl -X GET -I hytale-wiki.net
HTTP/1.1 200 OK
Server: nginx
Date: Sun, 20 Oct 2019 08:16:38 GMT
Content-Type: text/html; charset=utf-8
Content-Length: 900
Connection: keep-alive
X-Served-By: Namecheap URL Forward

$ curl -X GET -I hytale-market.net
HTTP/1.1 302 Found
Server: nginx
Date: Sun, 20 Oct 2019 08:16:42 GMT
Content-Type: text/html; charset=utf-8
Content-Length: 49
Connection: keep-alive
Location: https://spark-squared.com/
X-Served-By: Namecheap URL Forward

You need to point these to your webserver before you’ll be able to issue a certificate in this manner. Right now, Let’s Encrypt can’t see the challenge responses that get placed into your webroots.

3 Likes

Thank you _az for your quick reply.
I first had problems creating a record that points to /var/www/html/wikipedia for the domain “hytale-wiki.net”.

First I tried http:// numbers ip/wikipedia. [URL Redurect Record - Masked]
As you already mentioned, I got an error message from Letsencrypt that a number IP is not allowed.
My solution was to use the IP instead of the IP because I already linked the IP to the domain “hytale.forum.net”.

So for the domain “hytale-wiki.net” the link now looks like this:
http://hytale-forum.net/wikipedia
[URL Redurect Record - Masked]

This had also fixed my problem with LetsEncript. However, I could not add a domain.

I was just trying to enter the command you sent me. I’m just trying to be amateurish, but is this correct?
certbot certonly --cert-name hytale-forum.net --webroot -w /var/www/html -d hytale-forum.net -w /var/www/html/wikipedia -d hytale-wiki.net -w /var/www/html/marktplatz -d hytale-market.net --dry-run

When I enter this, I get the following message:
certbot: command not found

I hadn’t really linked the domain “hytale-market.net” yet, because I wanted to get “hytale-wiki.net” right first.

I made a quick change to make it easier to see:
http://hytale-wiki.net/ <- The link works, it leads to http://hytale-forum.net/, but is not encrypted with SSL.

Hi @Hytale_Forum

checking your domain there is no redirect http -> https - https://check-your-website.server-daten.de/?q=hytale-wiki.net

There is only a redirect

http://hytale-wiki.net/ -> http://hytale-wiki.net/index.php

So it’s a redirect http -> http, not a redirect to hytale-forum.net.

And https://hytale-wiki.net/ has a fatal redirect to http://hytale-wiki.net/index.php, so it’s a redirect https -> http. That’s always bad.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.