SSL on multiple subdomains on the same server

My domain is: and

I ran this command: sudo certbot certonly -a webroot --webroot-path=/<location_to_doc_root1>/lets-encrypt-validation -d --webroot-path=/<location_to_doc_root2>/lets-encrypt-validation -d

It produced this output: 2 different cert directories. is working fine. whereas fails

I also see that doesn’t retrieve any results although the command had worked fine in the server.

I also tried the below command to replace the existing cert for; the command completed fine but to no avail. Please help.
sudo certbot certonly -a webroot --webroot-path=/<location_to_doc_root_2>/lets-encrypt-validation -d

My web server is (include version): nginx

The operating system my web server runs on is (include version): Ubuntu 16.04

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

--webroot (without --standalone) may only work if the --webroot-path matches the root statement in your conf file.
Otherwise, let’s say:

  1. root /var/www/html/mysite
  2. –webroot-path /tmp/lets-encrypt-validation

looks for string file at:
but string file was placed at:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.