Winsimple error getting certificate


#1

Please fill out the fields below so we can help you better.

My domain is: bibliogw.biblio.gvcc.net

I ran this command: letsencrypt --test

It produced this output: ACME Server: https://acme-staging.api.letsencrypt.org/
Config Folder: C:\Users\administrator.DSBIBLIO\AppData\Roaming\letsencrypt-win-simple\httpsacme-staging.api.letsencrypt.org
Certificate Folder: C:\Users\administrator.DSBIBLIO\AppData\Roaming\letsencrypt-win-simple\httpsacme-staging.api.letsencrypt.org

Getting AcmeServerDirectory
Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: <. Path ‘’, line 0, position 0.
bei Newtonsoft.Json.JsonTextReader.ParseValue()
bei Newtonsoft.Json.JsonTextReader.Read()
bei Newtonsoft.Json.Linq.JObject.Load(JsonReader reader, JsonLoadSettings settings)
bei Newtonsoft.Json.Linq.JObject.Parse(String json, JsonLoadSettings settings)
bei Newtonsoft.Json.Linq.JObject.Parse(String json)
bei ACMESharp.AcmeClient.GetDirectory(Boolean saveRelative)
bei LetsEncrypt.ACME.Simple.Program.Main(String[] args)
Press enter to continue.

My operating system is (include version): Windows Server 2008 R2 RD Gateway

My web server is (include version): IIS 7.5

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):no

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#2

hi hubertkr

this is an issue with the client. looks like the configuration file can’t be parsed.

if you want to issue the certificate manually have a look at:

alternatively log a issue on the github of the client https://www.linkedin.com/pulse/lets-encrypt-part-1-issuing-installing-certificates-andrei-hawke?trk=mp-reader-card


#3

Ok thanks
Manually with zerossl the cert is working fine, on the other side i must care about the renewal myself.
I think the problem with winsimple is the account-path administrator.domain (the point raises an exception)
With my local administrator was no problem, winsimple worked like a charm


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.