Windows sServer 2012 :Automated renewals


#1

Hi,

lately I asked the forum how to set up “cronjob” under Windows which allows for running letsencrypt.exe automatically. So the answer was to use "“scheduled task” which is exactly true.

The point is when I run:
.\letsencrypt.exe --renew --baseuri “https://acme-v01.api.letsencrypt.org/

in order to renew all certificates without entering a dialog.
I get:

[ERROR] UnauthorizedAccessExeption: Access denied (Exception of HRESULT: 0x80070005 (E_ACCESSDENIED))

So Windows has access probs. Can you explain how to set the right access rights ?

Thanks!

Best,

Swantje


#2

Hi @swantje

the account which is used to run the scheduled task must have administrator rights.

The certificate must saved under MachineStore - Webhosting.

Changing the IIS-configuration needs also admin rights.


#3

Hi

You need to run as an admin - start, enter cmd.exe in the Search box, then right click > choose the option run as administrator. Don’t forget to restart after the changes have been made. My web server was previously on Ubuntu 16.04 so there were two basic modes to run (I used Standalone).

Best,
RJ Moonk
Munkied Brained Graphic designer do my project for me.


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.