Whats the AMI EC2 workflow to install Certbot


#1

Please fill out the fields below so we can help you better.

My domain is: www.fallenreaper.com

I ran this command: sudo yum install certbot

It produced this output:
Loaded plugins: fastestmirror, priorities, update-motd, upgrade-helper
Loading mirror speeds from cached hostfile

When trying to then run certbot certonly, it fails because it doesnt know the command.

My operating system is (include version): EC2 AMI

My web server is (include version): I run lighttpd

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

I have no clue what is going on, but i was following the None of the Above, CENTOS/RHEL 7 as i thought that was the closest to the Amazon Ec2 AMI instances. I was also looking into https://nouveauframework.org/blog/installing-letsencrypts-free-ssl-amazon-linux/ and that didnt work either.


#2

hi @Fallenreaper

Andrei


#3

Yeah I don’t use a standard webserver so I need to do some tweaking to get
Lighttpd to work with it.


#4

hmmmm

ok i don’t think you do

let me explain

There are 3 ways of installing certbot

A) System Packages (as explained above)
B) Using The Auto Script - explained here: https://certbot.eff.org/#pip-other
C) Using Python PIP manager - explained here (pip install certbot)

The web server you use only really affects how you may potentially use certbot to pass challenges rather than how you would install certbot

Andrei


#5

I ended up getting certbot working, now I’m trying to properly configure
everything with my files in Lighttpd. I think the issue was needing to make
sure I had correct versions of python and properly get the cert bot. Seemed
like it was corrupt a few times.


#6

I usually recommend building a new virtual environment and installing certbot in that

There can be lots of bad interactons between the OS installed python so a clean python environment sets you up for a good time

Andrei


#7

Ami instances run 2.6 by default (which I didn’t know at first) , so after
I aliased 2.7, wiped the corrupted directory, did some pip installs and
boom… It was smooth after that.


How to get SSL certificate, I have SSH and cPanel
Installing Lets Encrypt on godaddy cPanel Shared Hosting
#8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.