What steps need to be taken to turn from https to http in apache2 or nginx?

server ubuntu not through cpanel or any program just linux ,
I have been trying to manually delete the certification with certbot-auto and return from https to http and when I deleted and revoked the certificate my wordpress site stopped working 404 error… I need help to understand what process do I need to do in order to switch from https to http so my site would work again without the https e.g --> http://mydomain.com
help is much appreciated,

Hi @shahar99,

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi @schoen
My domain is: I have 2 domains one on nginx server and one on apache2 server
nginx: domainhuntr.com, apache2: maxserp.com

I ran this command exactly as written here no change whatsoever:
on nginx:
sudo certbot-auto delete --cert-name domainhuntr.com
rm -rf /etc/letsencrypt/live/domainhuntr.com
rm -rf /etc/letsencrypt/renewal/domainhuntr.com.conf
rm -rf /etc/letsencrypt/archive/domainhuntr.com

on apache2:
sudo certbot-auto delete --cert-name maxserp.com
rm -rf /etc/apache2/sites-available/maxserp.com.conf
source /etc/apache2/envvars
sudo systemctl restart apache2

It produced this output:
It told me on both servers that the certificate was deleted and I had no error but when I’m trying to get into my site it tells me “site cannot be reached”
and it still redirects my site to https
on apache2 maxserp.com it says something like limit of certificates exceeded means I can’t ask for anymore certificates on this domain need to fix this also

My web server is (include version):
nginx version: nginx/1.15.5 (Ubuntu)
apache2 Server version: Apache/2.4.38 (Ubuntu)

The operating system my web server runs on is (include version):
using nginx Ubuntu 18.10 (GNU/Linux 4.18.0-20-generic x86_64)
using apache2 Ubuntu 19.04 (GNU/Linux 5.0.0-15-generic x86_64)

My hosting provider, if applicable, is:


I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
using certbot-auto --version
on nginx: certbot 0.36.0
on apache2: certbot 0.36.0

I just want to know what processes I need to do for making my site work after deleting the certificate go from https to http

Hi @shahar99

this domain has no https and no redirect http -> https ( https://check-your-website.server-daten.de/?q=domainhuntr.com )

Domainname Http-Status redirect Sec. G
http://www.domainhuntr.com/
149.28.72.25 301 http://domainhuntr.com/ 0.340 D
http://domainhuntr.com/
149.28.72.25 200 0.514 H
https://domainhuntr.com/
149.28.72.25 -2 1.486 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 149.28.72.25:443
https://www.domainhuntr.com/
149.28.72.25 -2 1.486 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 149.28.72.25:443

So there is no problem.

Same with your second domain ( https://check-your-website.server-daten.de/?q=maxserp.com ):

Domainname Http-Status redirect Sec. G
http://www.maxserp.com/
155.138.210.173 301 http://maxserp.com/ 0.264 D
http://maxserp.com/
155.138.210.173 200 0.290 H
https://maxserp.com/
155.138.210.173 -4 0.480 W
SendFailure - The underlying connection was closed: An unexpected error occurred on a send. The handshake failed due to an unexpected packet format.
https://www.maxserp.com/
155.138.210.173 -4 0.484 W
SendFailure - The underlying connection was closed: An unexpected error occurred on a send. The handshake failed due to an unexpected packet format.
http://www.maxserp.com:443/
155.138.210.173 301 http://maxserp.com/ 0.260 Q
Visible Content:
http://maxserp.com:443/
155.138.210.173 200 0.280 Q

Port 443 answers, but wrong, there is a http answer.

But there is no redirect http -> https.

So if you see such redirects, it’s only the cache of your browser.

@JuergenAuer There is a problem because I already deleted the certificate but still i can’t reach my site because letsencrypt changed my regular settings plz read the ticket from the beginning, I need to turn the setting as it was before I installed letsencrypt in my
server settings how can I do deletion of certificates and letsencrypt from my servers with my regular server settings, I need to know the process needed to be done in order for it to get my server like before the certificating process

Please read my answer. You can’t check such things with your browser.

So you have to use online tools.

And there is no problem visible. http works and has no redirects to https. So if you see a redirect, it’s only your browser cache. Nothing public.

The only visible problem: You don’t use a certificate and https.

2019, that’ terrible.

@JuergenAuer @schoen can you direct me to the online tools needed for making such a process?
and why can’t I ask for certificates anymore for maxserp.com
and which files need to be edited in order to put everything like the way it was before?

Use your backup. There is your old configuration.

Sorry i’m kinda new to this but where is that backup supposed to be? @JuergenAuer

Look I need help because my site is not working and it was ever since I removed your certificate lets encrypt and I need someone pro with better answers that knows what’s going on behind the scenes inside the server when you install a SSL certification…
who can help me? l need to know what files are being edited with your certbot that determine the redirection of http to https…

As written and shown - What steps need to be taken to turn from https to http in apache2 or nginx?

Your site works. It’s only a problem of your browser cache.

So clear your browser cache.

There - https://check-your-website.server-daten.de/?q=domainhuntr.com - is a new check of your domain:

Domainname Http-Status redirect Sec. G
http://domainhuntr.com/
149.28.72.25 200 0.337 H
http://www.domainhuntr.com/
149.28.72.25 200 0.330 H
https://domainhuntr.com/
149.28.72.25 -2 1.493 V
ConnectFailure - Unable to connect to the remote server No connection could be made because the target machine actively refused it 149.28.72.25:443
https://www.domainhuntr.com/
149.28.72.25 -2 1.487 V

Your http works, your https is blocked. You don’t want https, so all is done.

PS: If you don’t want to use https, why do you create 3 certificates today?

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2019-07-15 2019-10-13 domainhuntr.com - 1 entries duplicate nr. 5 next Letsencrypt certificate: 2019-07-16 14:27:35
Let’s Encrypt Authority X3 2019-07-15 2019-10-13 domainhuntr.com - 1 entries duplicate nr. 4
Let’s Encrypt Authority X3 2019-07-15 2019-10-13 domainhuntr.com - 1 entries duplicate nr. 3
Let’s Encrypt Authority X3 2019-07-13 2019-10-11 domainhuntr.com - 1 entries duplicate nr. 2
Let’s Encrypt Authority X3 2019-07-09 2019-10-07 domainhuntr.com - 1 entries duplicate nr. 1

@JuergetAuer I needed to test your organization’s service but I try to delete it for when I no longer need your service
I think I found the problem…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.