Http to https don't show up correctly

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: walk3r.info

I ran this command:

It produced this output:

My web server is (include version): apache2

The operating system my web server runs on is (include version): debian 10

My hosting provider, if applicable, is: private server

I can login to a root shell on my machine (yes or no, or I don’t know):yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): wordpress dashboard

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):certbot 0.31.0

I can’t figure out my problem. My website works well on http. but when i redirect to https with apache2 the website don’t show up correctly.

My apache2.conf:

<VirtualHost *:80>
ServerName walk3r.info
DocumentRoot /var/www/wordpress
#Redirect permanent / https://walk3r.info/

</VirtualHost

<IfModule mod_ssl.c
<VirtualHost *:443

ServerName walk3r.info
ServerAlias www.walk3r.info
ServerAdmin contact@domain.tld
DocumentRoot /var/www/wordpress

ErrorLog ${APACHE_LOG_DIR}/error.log

CustomLog ${APACHE_LOG_DIR}/access.log combined

SSLCertificateFile /etc/letsencrypt/live/walk3r.info/cert.pem
SSLCertificateKeyFile /etc/letsencrypt/live/walk3r.info/privkey.pem
SSLCertificateChainFile /etc/letsencrypt/live/walk3r.info/fullchain.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost
</IfModule

Hi @dukeluke

checking your domain via https://check-your-website.server-daten.de/?q=walk3r.info - your certificate is correct.

CN=walk3r.info
	05.06.2020
	03.09.2020
expires in 90 days	walk3r.info - 1 entry

But

  • your chain is wrong
  • and really bad: You have a lot of ip addresses in links:
https://192.168.178.100/wordpress/wp-content/plugins/elementor/assets/css/frontend.min.css?ver=2.9.11

That’s a private ip address, not a public. And you would need a certificate with that ip address as domain name.

Change all of these links, so your domain name is used -> no Grade I - content errors.

Same with your links.

Thx for your answer, but what links should be changed where?

Reinstalled Wordpress… now it works

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.