Website doesn't work after I delete certificate

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g., so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version): AWS Lightsail

My hosting provider, if applicable, is: AWS

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):

Hi, I tried to install the certificate but keep getting error, so I have deleted it using sudo certbot delete command. But now my website couldn’t load anymore, please help.

Hi @skye

that's always wrong. Never delete valid and used certificates without a backup.

So use your backup to fix your configuration. If you don't have a backup, that's the next basic problem -> never delete files if you don't have a backup.

So you have two options:

  • install a self signed certificate (or)
  • remove the not working port 443 complete
1 Like

Can you please guide me how to remove the not work port 443? I am not a technical business and first time setting this up in AWS. Thank you.

I might have a backup too. How do I retrieve it?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.