Webroot - Invalid key authorization


I receive an error:
The client lacks sufficient authorization :: Error parsing key authorization file: Invalid key authorization: 6 parts .

But when i create a file manual, all is given to normal.

example/public_html/.well-known/acme-challenge [0] # curl 'http://example.ru/.well-known/acme-challenge/testfile
example/public_html/.well-known/acme-challenge [0] # cat testfile

Where is the mistake ?

what command line are you running ? have you got he webroot directory correct ?

Yep, directory is correct. And command line is correctly too. Failed requests 6 out of 1,000.

Without seeing the command line you used, or knowing the domain it becomes very difficult to help.

The most common reason is that the webroot path is wrong

The next is either a folder / file permission issue or a htaccess / redirect issue.

Command like :

" certonly --webroot {0} --text --renew-by-default --email {1} --break-my-certs --agree-tos".format(command,LETSENCRYPT_EMAIL)

I don’t think what reason in this command. Domain 3d-advisor.ru.

http://3d-advisor.ru/.well-known/acme-challenge/testfile isn't returning a plain text file for me, you may need to change your config for that location

< html>< head>< script>function set_cookie(){var now = new Date();var time = now.getTime();time += 19360000 * 1000;now.setTime(time);document.cookie='beget=begetok'+'; expires='+now.toGMTString()+'; path=/';}set_cookie();location.reload();;< /script>< /head>< body>< /body>< /html>

Please tell me that it is for “Invalid key authorization: 6 parts .” ? What the “6 parts”?

And can u tell me what has in logs about it?
What’s the key expected and received ?

You need to turn on debug, and paste your full log for me to tell exactly what the 6 parts were;

You can use the -v, --verbose flag can be used multiple times to incrementally increase the verbosity of output

The key ( token) is effectively a random string for the file name which includes another random string within it ( hence why you need to return that as plain text ). In reality they aren't completely random, but in effect it looks that way.

How i can turn on debug ?

Add -vv to the command line.