wacs/IIS Certificate fails - no obvious error

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:www.techneat.co.uk, www.techneatengineering.co.uk, www.techneatrotomoulding.co.uk

I ran this command: C:\bin\letsencrypt\wacs.exe >> Interactive, Simple

It produced this output:

Common name: 4

1: techneat.co.uk (Site 10)
2: techneatengineering.co.uk (Site 10)
3: techneatrotomoulding.co.uk (Site 10)
4: www.techneat.co.uk (Site 10)
5: www.techneatengineering.co.uk (Site 10)
6: www.techneatrotomoulding.co.uk (Site 10)

Continue with this selection? (y*/n) - yes

Target generated using plugin IIS: www.techneat.co.uk and 5 alternatives
Authorize identifier: techneat.co.uk
Authorizing techneat.co.uk using http-01 validation (SelfHosting)
Authorization result: pending

Create certificate failed, retry? (y/n*) -

Create certificate failed: Authorization failed

My web server is (include version): IIS 10.0.17763.1

The operating system my web server runs on is (include version): Windows Server 2019 version 1809

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): Don't know

I'm not sure if this is a related issue but I notice that when I go to C:\bin\letsencrypt\wacs.exe via the command prompt, I get the following, which is not something I've seen before:

Error creating event logger: Could not find file 'C:\Users\user\AppData\Local\Temp.net\wacs\mj3svjlg.rjc\wacs.deps.json'.
Error creating disk logger: Could not find file 'C:\Users\user\AppData\Local\Temp.net\wacs\mj3svjlg.rjc\wacs.deps.json'.

Just on the off chance I created a new .json file there but this gave a breaking error
There are several sites on this server with Lets Encrypt SSL certs which all work fine, including some recent enough renewals.

I have tried https://letsdebug.net/ and no issues


I'd recommend posting this question to win-acme/win-acme · Discussions · GitHub - make sure you are testing on the very latest version of the app.


Thanks you - I'm fairly new at this and didn't know the difference. I ended up installing a newer version and it worked.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.