Update your client software to continue using let's encrypt

from the error it sounds like I have to update my certbot client, but I just want to make sure there is no other part to this I have to do.

because before doing anything, I upgraded

$ sudo apt-get update
$ sudo apt-get install --only-upgrade certbot

and got the message:

certbot is already the newest version (0.31.0-1+ubuntu16.04.1+certbot+1).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Am I really finished without doing anything?

1 Like

Could you show the error message and where/how you got it?

Also, can you show?:
apt list --upgradeable

…just curious about the:

1 Like

the only error I got was the above error, and when I list upgradables:

$ apt list --upgradeable -a

Listing... Done

cloud-init/xenial-updates 19.4-33-gbb4131a2-0ubuntu1~16.04.1 all [upgradable from: 0.7.9-153-g16a7302f-0ubuntu1~16.04.2]

cloud-init/now 0.7.9-153-g16a7302f-0ubuntu1~16.04.2 all [installed,upgradable to: 19.4-33-gbb4131a2-0ubuntu1~16.04.1]

cloud-init/xenial 0.7.7~bzr1212-0ubuntu1 all

my certbot does not appear to be the latest version. Is that the problem? I can’t upgrade it.

1 Like

Too soon to tell, please show where/how you get the error message.

1 Like

The error comes from the following command:

$ sudo apt-get install --only-upgrade certbot
1 Like

I’m confused…
Can you show a screenshot?
[that contains the error message and anything leading to it]

1 Like

The title of this topic is:
“Update your client software to continue using let’s encrypt”

Where did you receive that message?

1 Like

you may need to check your configuration files for each domain you are trying to renew.

the configuration file may have a setting which points to a renewal server which is using version 01

change it to version 02

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.