Unexpected error 429


#1

Hello,

I’m trying to issue a certificate consisting of 6 domain names, but I’m hitting error 429, saying I have too many pending authorizations. I have not been issuing any certificate for the past days, and weeks have passed since last time I first tried issuing this cert in particular, so it looks like some kind of permanent issue. What could be the culprit?


#2

Are you certain that you don’t have a cron or anything running which could be making requests by accident (that you intended for renewals ) ?

are you on a shared server ? or a dedicated server ?


#3

Thanks for your answer!

There’s no letsencrypt-related cronjob (nor any certificate-related at all), I’m on a dedicated server and I’m the only one with root access.


#4

well the rate limits for pending authorizations are 300 per account per week.

Can I ask what you sort of commands / what have you been trying in the week ? it is slightly odd if you haven’t had any certificate related cron running to have reached this limit - which is basically that you have requested a domain name be authorized without actually fulfilling on the request itself and obtaining the certificate.


#5

I solved the problem.
Seems to be some issue with the Webmin module when using its tiny-acme client. I installed the letsencrypt client to let Webmin use that instead (from jessie-backports) and it worked.
No idea why tiny-acme was triggering a ratelimit error, unless it was having issues parsing an error coming from LE, which was actually related to a A record missing but in no way related to ratelimits. Perhaps a Webmin bugreport about this should be created. Makes way more sense now.
Thank you for your assistance!


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.