Unauthorized domain


#1

hello

My domain is: anavid.eu

I ran this command: /opt/letsencrypt/letsencrypt-auto

It produced this output:

My web server is (apache2)

My hosting provider, if applicable, is: Amazon

I can login to a root shell on my machine (yes)

I’m using a control panel to manage my site (yes):


#2

Hi,

What plugin did you choose to complete this verification? (Nginx? Apache? Webroot?)

Could you please try to place a test file under $document-root/.well-known/acme-challenge/ ?

Thank you


#3

Hi Stevenzhu,
I flowed this tuto https://www.grafikart.fr/tutoriels/apache-ssl-letsencrypt-746.
The file .well-known is under the folder /opt/lampp/htdocs.
I try to added a file test.html under /opt/lampp/htdocs/.well-known/acme-challenge/ and it worked fine. Please helpe me to find the issue.


#4

Please if anyone can help me to resolve this problem :frowning:


#5

If you ran that command, it would have asked you to make some choices and perhaps enter some information. Could you please show us the complete output, including anything you typed in yourself?


#6

Hi @dev26

there is no file:

http://anavid.eu/.well-known/acme-challenge/test.html

doesn’t exist. If this works, you have found your correct webroot. So you can use it.

certbot run -a webroot -i apache -w yourWebroot -d anavid.eu