Unable to upload files to namecheap

This is what Namecheap told me. What do I do next?

“According to our SSL representative checks, unfortunately, we will not be able to validate the SSL certificate for this domain, as this certificate is not purchased with us. You should contact your current SSL provider for help. Still, if you have an SSL Certificate, CA Bundle and Private Key, you can contact our SSL department who will help you to install the certificate on the server side.”

My domain is: hpriestess.com

I ran this command: Tried to upload files to acme-challenge

It produced this output: would not upload

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is: Namecheap

I can login to a root shell on my machine (yes or no, or I don’t know): I don’t know

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): Cpanel

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): ?

1 Like

Why not? How did you try to upload the file? Could you provide a screenshot of what didn't work?

It should work using something like cPanel's File Manager.


I tried to upload the way Namecheap said to. There is nothing to screenshot but an empty file. Nothing happens when I try to upload to cpanel. It will not allow me to upload. I contacted Namecheap and the above is what they told me. I have to supply them with an SSL Certificate, CA Bundle and Private Key and they will help me install it. I do not know how to get these things from here.

1 Like

Namecheap support are jumping the gun.

You will be able to send them the certificate files only after you actually create the certificate.

Uploading the acme-challenge file is a required step on the way to that goal.

It would help if you could be more precise about what is going wrong with the upload.

What method are you using to try and upload the file? FTP? cPanel File Manager? WordPress?

1 Like

Using cpanel. Acme-challenge folder already existed, i tried to upload files needed for this, using cpanel, it seemed to work, but the new files did not show up. I tried again and nothing happened that time. So I deleted the files that already existed, that oddly deleted the acme-challenge folder. I recreated that folder and tried to upload these files again and nothing happened. It seems to be ignoring my attempts to upload the files.

That is all that is happening.

1 Like

So they did not show up in cPanel's File Manager after the upload?

If that's the case, I would try setting up an FTP account in cPanel, and using an FTP client to upload the challenge file.

You can use a program such as WinSCP to do the job.

Annoying, but possibly less annoying than having to explain the issue to Namecheap support ...


I know it’s not an answer to the original question, but I recommend switching hosting provider to one which supports Let’s Encrypt out of the box.

Even if you get things to work now, you’d have to repeat this manual process at least once every 3 months (< 90 days). I do not recommend that.


I was finally able to do it using the FTP option on the sslforfree.com page. I had watched a tutorial that told me to use the manual option and cpanel. After digging out all of the information needed, it went smoothly. Thank you for mentioning FTP or I would have just given up. Namecheap was not at all helpful with this and any instructions on their site are incomplete, this is across the board. Frustrating.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.