Unable to obtain ACME certificate for domains

My domain is: cloud.[redacted].de

I ran this command: none (Using Traefik Proxy)

It produced this output:

level=error msg="Unable to obtain ACME certificate for domains "cloud.[redacted].de": unable to generate a certificate for the domains [cloud.[redacted].de]: error: one or more domains had a problem:\n[cloud.[redacted].de] acme: error: 400 :: urn:ietf:params:acme:error:connection :: [redacted]: Connection refused\n" routerName=nextcloud-nextcloud-ingress-804021c36284ed13b9bd@kubernetescrd rule="Host(cloud.[redacted].de) && PathPrefix(/)" providerName=letsencrypt-prod.acme ACME CA="https://acme-staging-v02.api.letsencrypt.org/directory"

My web server is (include version): Traefik version 2.8.5 built on 2022-09-13T15:19:09Z

The operating system my web server runs on is (include version): Kubernetes on Ubuntu 22.10

I can login to a root shell on my machine (yes or no, or I don't know): Yes

Logs do say that the LE Server can not connect to the IP but I have tested it, its open!
Also, I ran letsdebug.net which also said

All OK!
No issues were found with cloud.[redacted].de. If you are having problems with creating an SSL certificate, please visit the Let's Encrypt Community forums and post a question there.

Edit: I updated to the latest version of traefik and it worked for the staging server .. but on LE Prod server, I still face the same issue (could not connect to IP)

Any Ideas?

Do you block some IP addresses, some countries, or similar?


I srsly have no Idea what was wrong the last 2 weeks but now it renewed the certificates just fine.
(btw. ssllabs also had no problem)

anyway, thanks :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.