Unable to install route53 plugin

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

It produced this output:
Could not choose appropriate plugin: The requested dns-route53 plugin does not appear to be installed
The requested dns-route53 plugin does not appear to be installed

My web server is (include version):
N/A trying to perform DNS validation

The operating system my web server runs on is (include version): N/A running on Ubuntu 18.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Ubuntu works with AWS as I launch formation scripts from this machine all the time, and has the appropriate permissions set.

Steps taken to install route 53 plugin are as follows:
pip install certbot_dns_route53==0.31.0

ran the command above and got not installed
so i ran this install command
pip install certbot_dns_route53

reran the above cammand and still nothing.

How did you install Certbot?

If you’re using the Ubuntu packages, apt install python3-certbot-dns-route53.

Installing parts of Certbot – or all of Certbot – with pip is not encouraged.

I installed [quote=“mnordhoff, post:2, topic:97508”]
apt install python3-certbot-dns-route53
[/quote] and it worked,

I don’t know. :confused: Does it work if you try again?

demo.insight-nesa.com is a separate hosted zone… It looks like it’s configured correctly, and it ought to work, but maybe there’s a bug?

Can you post /var/log/letsencrypt/letsencrypt.log from when it failed?

Hi @CompactRaptor

I would try to create a test-certificate with your main domain. To see, if your --dns-route53 works.

Forget about the second attempt. listener.demo.insishgt-nesa.com. How do I copy my certificates to other servers? When I copy to the desktop I to prepare to zip te folder I am unable to view the certificates.

Just just created a wild card certificate and I am unable to copy the certificates to the server in AWS. When I sudo cp -r to the desktop and try to view the file it says it is broken? ow do I ocpy it to my online server?

Hi @CompactRaptor,

If you created it with Certbot, the items in /etc/letsencrypt/live are symbolic links (wihch other operating systems call “aliases” or “shortcuts”) to other files in /etc/letsencrypt/archive. Copying only items from /etc/letsencrypt/live to a new location without also copying /etc/letsencrypt/archive to the corresponding location won’t work for this reason.

We structured it this way because Certbot is meant to be used with automated renewals, so it keeps track of various things that are used for this purpose within /etc/letsencrypt. Then running certbot renew should automatically update all of your certificates by reissuing ones that are near expiry (although this feature isn’t available for wildcard certificates if you used --manual and created DNS records manually).

If you want to copy the individual certificates and associated files over manually (and you’re willing to repeat this process whenever you renew the certificates), you could find them in /etc/letsencrypt/archive. If you want to copy the whole structure, consider using rsync -a to copy all of /etc/letsencrypt onto the other machine (then the symbolic links will work).

Alternatively, maybe you could run Certbot on the AWS server itself rather than on a separate machine. In many configurations, this will produce a nicer experience because Certbot can create and update the certificate files on the same machine where they’re going to be used.

I’ve also just moved this question into your existing thread (although I understand that your later question relates to a different part of your problem).

Yes I was copying the incorrect folder. Thank you so much. It was for the purpose of importing the certificate into AWS.