Unable to determine base domain for using names ['domain.com','com']

My domain is:


I ran this command:

sudo certbot certonly --server https://acme-v02.api.letsencrypt.org/directory --dns-digitalocean --dns-digitalocean-propagation-seconds 60 --dns-digitalocean-credentials ~/do-creds.ini -d “*.svisionx.com” -d svisionx.com

It produced this output:

Encountered exception during recovery:
Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/certbot/auth_handler.py”, line 75, in handle_authorizations
resp = self._solve_challenges(aauthzrs)
File “/usr/lib/python3/dist-packages/certbot/auth_handler.py”, line 139, in _solve_challenges
resp = self.auth.perform(all_achalls)
File “/usr/lib/python3/dist-packages/certbot/plugins/dns_common.py”, line 57, in perform
self._perform(domain, validation_domain_name, validation)
File “/usr/lib/python3/dist-packages/certbot_dns_digitalocean/dns_digitalocean.py”, line 47, in _perform
self._get_digitalocean_client().add_txt_record(domain, validation_name, validation)
File “/usr/lib/python3/dist-packages/certbot_dns_digitalocean/dns_digitalocean.py”, line 76, in add_txt_record
domain = self._find_domain(domain_name)
File “/usr/lib/python3/dist-packages/certbot_dns_digitalocean/dns_digitalocean.py”, line 163, in _find_domain
.format(domain_name, domain_name_guesses))
certbot.errors.PluginError: Unable to determine base domain for svisionx.com using names: [‘svisionx.com’, ‘com’].

My web server is (include version):

nodejs 8.10.0

The operating system my web server runs on is (include version):

ubuntu 18.04

My hosting provider is:


I can login to a root shell on my machine (yes or no, or I don’t know):


The version of my client is :

certbot 0.31.0

1 Like

Hi @sqro2

is digitalocean your dns provider?

Your domain is parked ( https://check-your-website.server-daten.de/?q=svisionx.com ):

Host T IP-Address is auth. ∑ Queries ∑ Timeout
svisionx.com A yes 1 0
AAAA yes
www.svisionx.com C parkingpage.namecheap.com yes 1 0
A yes
A yes
A yes
A yes
A yes
A yes
A yes


	•  dns1.registrar-servers.com	•
	2620:74:19::33	•
	•  dns2.registrar-servers.com	•
	2001:502:cbe4::33	•

is your name server.

Doesn't look like a digitalocean name server.

1 Like

thanks for the response. So I must configure the nameservers in namecheap to digitalocean nameservers before proceeding to create the widcard cert?

and I’ve tried this one - alumni.tezu.ac.in (which has digitalocean nameserver)

returns the same error -

Unable to determine base domain for alumni.tezu.ac.in using names: [‘alumni.tezu.ac.in’, ‘tezu.ac.in’, ‘ac.in’, ‘in’]

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.