Unable to create SSL Certificate for Filemaker on Mac M1 and Monterey

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: http://bienz.internet-box.ch

I ran this command: sudo ./GetSSL.sh

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Requesting a certificate for bienz.internet-box.ch

Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
Domain: bienz.internet-box.ch
Type: connection
Detail: Fetching http://bienz.internet-box.ch/.well-known/acme-challenge/LxkTqfAxIYW5K-268MLrADi5l053G9saYmP48Rc63sk: Timeout during connect (likely firewall problem)

Hint: The Certificate Authority failed to download the temporary challenge files created by Certbot. Ensure that the listed domains serve their content from the provided --webroot-path/-w and that files created there can be downloaded from the internet.

Some challenges have failed.
Ask for help or search for solutions at https://community.letsencrypt.org. See the logfile /var/log/letsencrypt/letsencrypt.log or re-run Certbot with -v for more details.
cp: /etc/letsencrypt/live/bienz.internet-box.ch/fullchain.pem: No such file or directory
cp: /etc/letsencrypt/live/bienz.internet-box.ch/privkey.pem: No such file or directory
chmod: /Library/FileMaker Server/CStore/privkey.pem: No such file or directory
mv: rename /Library/FileMaker Server/CStore/serverKey.pem to /Library/FileMaker Server/CStore/serverKey-old.pem: No such file or directory
fmsadmin: really delete certificate? (y, n) (Warning: server needs to be restarted)

My web server is (include version): Filemaker Server

The operating system my web server runs on is (include version): macOS Monterey (v12.1) on a Mac mini (M1 2020)

My hosting provider, if applicable, is: my own mac mini

I can login to a root shell on my machine (yes or no, or I don't know): I don't know (I am not experienced and do not know, how to test this)

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I do not know

• I used the same "GetSSL.sh" with my older mac mini (Mac mini (late 2014), Catalina 10.15.7) with the same settings for Filemaker and for safety options in the preferences of the OS), an it worked well.
• I try to replace the older server with a newer one; In the router, I have changed the port forwardings to the new machine.

You will need a functional HTTP site before it can be secured (via HTTP authentication).

1 Like

How can I do that with Filemaker? I have activated WebDirect, which should provide the HTTP function, and forwarded the respective port 80. This works fine with the Mac mini running Catalina but evidently not with the new one running Monterey (on M1). Is there a setting in the Mac OS that has to be activated/deactivated? Is there another possibility to install a functional HTPP site?



Those are basic questions that aren't best answered by this forum.

Does the site work within the same network?
If the firewall/NAT device configured properly?
[food for thought - answers NOT expected]

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.