Unable to create cert on Fortigate Appliance

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: larsmyhreostfold.no

I ran this command: Tried creating cert within Fortigate UI

It produced this output: Creating new order
Creating new ACME account for larsmyhreostfold.no
Selecting account to use for larsmyhreostfold.no
Driving ACME protocol for renewal of larsmyhreostfold.no
Resetting staging for larsmyhreostfold.no
Contacting ACME server for larsmyhreostfold.no at https://acme-v02.api.letsencrypt.org/directory
Assessing current status
Resetting staging area
Checking staging area
Starting challenges for domains
Cannot negotiate ALPN protocol "acme-tls/1" for tls-alpn-01 challenge
Starting challenges for domains: Cannot negotiate ALPN protocol "acme-tls/1" for tls-alpn-01 challenge, problem: urn:ietf:params:acme:error:unauthorized

My web server is (include version): Fortigate 60E

The operating system my web server runs on is (include version): 7.0.4

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): NP

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): N/A

Is that appliance reachable on port 443 on the domain(s) you are trying to get a certificate for?

1 Like

As it turns out, it wasn't.
I took for granted that it was, and didn't bother to check.

Thanks for the help :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.