Unable to check the TXT record: ### Unexpected HTTP status: 403

I tried to use cert-manager and letsencrypt to generate a ceritificate for godaddy domain but i got an issue:
cert-manager-logs: Unable to check the TXT record: ### Unexpected HTTP status: 403]

I followed this repo: GitHub - snowdrop/godaddy-webhook: Cert Manager Godaddy Webhook performing ACME challenge using DNS record

note that the api:key is working fine when i run :
curl -X GET -H "Authorization: sso-key $key:$secret" "https://api.godaddy.com/v1/domains/available?domain=adeiz.com"
result: `` {"available":false,"definitive":true,"domain":"adeiz.com"}

Hello @Siradjedd, welcome to the Let's Encrypt community. :slightly_smiling_face:

Here is a list DNS providers who easily integrate with Let's Encrypt DNS validation

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. crt.sh | example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know):

I'm using a control panel to manage my site (no, or provide the name and version of the control panel):

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Thank you for assisting us in helping YOU!

1 Like

Here are a few links to check:

3 Likes

I don't know that api very well but are you sure that is a successful response?

Because I see "available":false and the docs for that api endpoint show a successful request with true

https://developer.godaddy.com/doc/endpoint/domains#/v1/available

What do the response headers look like if you add -i to the curl request like

curl -i -X GET -H "Authorization: ...
3 Likes

it is false cause its already used if i type random domain it results "true", when i adedd -i i got http status 200.

when i try to get records using same apikey:secret using this api :
curl -i -X 'GET' 'https://api.ote-godaddy.com/v1/domains/adeiz/records/SRV/_acme-challenge' -H 'accept: application/json' -H 'Authorization: sso-key key:secret'

i got: {"code":"UNABLE_TO_AUTHENTICATE","message":"Unauthorized : Could not authenticate API key/secret"

1 Like

Hopefully you get a response to your github post. Or try GoDaddy support. Maybe someone here will know. My only idea is to switch to a different DNS provider with better API support. Best of luck

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.