Unable to Add Subdomain to Existing Certificate

I’ve replace my domain name with example.com. The issue I’m having is that I have an existing certifcate for example.com and www.example.com, but when I try to add mail.example.com, it acts like it adds it, but it doesn’t. When I run ./letsencrypt-auto certificates, it only lists example.com and www.example.com under Domains for the certificate in question.

I’ve tried both of the following commands multiple times
./letsencrypt-auto certonly --standalone --expand -d example.com,www.example.com,mail.example.com
./letsencrypt-auto certonly --standalone --cert-name example.com -d example.com,www.example.com,mail.example.com
This second one even asks me “You are updating certificate example.com to include domains: example.com, www.example.com, mail.example.com / It previously included domains: example.com, www.example.com / Did you intend to make this change? / (U)pdate cert/©ancel” I press “U” and it goes through the process like it’s going to update the certificate and says everything’s fine, but the actual certificate doesn’t get the domains added. And, if I re-run the exact same command, it asks me the exact same question again…

I got tired of banging my head against this. I just deleted the certificate and started from scratch. That appears to have fixed the problem.

I'm pretty sure this was partly to blame:

I would like to see the exact output of the Certbot command in this case, if possible.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.