Ubuntu 18.04 Type: unauthorized

My domain is: www.moelanz.be, www.moelanz.com

I ran this command: sudo certbot --apache -d www.moelanz.be -d www.moelanz.com

It produced this output: Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for www.moelanz.be
http-01 challenge for www.moelanz.com
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.moelanz.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.moelanz.com/.well-known/acme-challenge/egoXEYlmrgGQjkof7cUDWYKaWAVF-a7_-roUdF-yCvA [2a00:f10:305:0:1c00:dfff:fe00:4be]: “\n\n\n\n\n \n <meta http-equiv=“Content-type” content=“text/html; charset=utf-8”>\n <meta http-equi”, www.moelanz.be (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.moelanz.be/.well-known/acme-challenge/M3OYATBf9ejW6J0yIGCFfQcnB9pJoWnjaHyAhxzUGJc [2a00:f10:305:0:1c00:dfff:fe00:4be]: “\n\n\n\n\n \n <meta http-equiv=“Content-type” content=“text/html; charset=utf-8”>\n <meta http-equi”


My web server is (include version): Apache2

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: Digital Ocean Droplet

I can login to a root shell on my machine.

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Extra info: I tried creating a ACME test and that worked

I tried many step by step guides and searched through lots of support topics. But non of those could help me.

You have an errant IPv6 (AAAA) record in your DNS, pointing to a different web server to your IPv4 (A) address: https://letsdebug.net/www.moelanz.be/50357

You’ll be wanting to login to your DNS management to either update the AAAA record to the correct value, or removing it entirely.

1 Like

Thanks I did not change these on registering the DNS. I now deleted thos records and it is working.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.