{ "type": "urn:ietf:params:acme:error:malformed", "detail": "Method not allowed", "status": 405 }

I am trying to create a certificate, but I ran into the following error while trying to create a Cluster Issuer.

{
"type": "urn:ietf:params:acme:error:malformed",
"detail": "Method not allowed",
"status": 405
}

I used the following commands
$ helm install cert-manager jetstack/cert-manager --namespace cert-manager-new --version v1.3.0 --set installCRDs=true

apiVersion: cert-manager.io/v1
kind: ClusterIssuer
metadata:
  name: letsencrypt-staging
spec:
  acme:
    email: mmadiawetsa@yahoo.com
    server: https://acme-staging-v02.api.letsencrypt.org/directory
    privateKeySecretRef:
      name: example-issuer-account-key
    solvers:
    - http01:
        ingress:
          class: nginx

$ kubectl apply -f .yaml

helm 3.5.2
Kubernetes EKS 1.16
cert-manager 1.3.0

1 Like

I'm not familiar with that specific tool, but that type of error would generally indicate a bug in the ACME client not sending a correct request to Let's Encrypt's servers. (Or perhaps, some misconfiguration that's not checked for or reported well, that then leads to it sending bad requests later in the process.)

It's possible somebody else here can point you in the right direction, but you might also want to check if there's some cert-manager specific support options available as well.

1 Like

Potentially related: my orders keeping returning 405 · Issue #2954 · jetstack/cert-manager · GitHub

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.