TXT record ins't propagation with name "_acme-challenge"

I’m problem to configurate SSL in my domain quasebuda.com that is hosted in Godaddy.
When configured a TXT like this:

TXT _acme-challenge.quasebuda.com PUhUPUz... 600 segundos

There ins’t propagation, but when configured a TXT like this:

TXT @ PUhUPUz... 600 segundos

There is propagation, but certbot can not verify my domain because not have the name “_acme-challenge.quasebuda.com” and yes the name “.quasebuda.com” that is the same that “@” in my case.

So, I’m searching in the web and finded that should configure the name to “_acme-challenge.quasebuda.com” and yes to “_acme-challenge.cam”, like this:

TXT _acme-challenge.cam PUhUPUz_Dqm6tmjpV_6jrzqwujHoXgzGopK85s8bXD0 600 segundos

There ins’t propagation. So I’m tryed also:

TXT _acme-challenge PUhUPUz_Dqm6tmjpV_6jrzqwujHoXgzGopK85s8bXD0 600 segundos

and also there ins’t propagation.

I don’t know what to try anymore.

Sorry if my english is wrong. I’m study english and I’m tryed not using google translation. You can correcting me, it help me.

Hi @quasebuda

checking your domain there is no correct and no wrong TXT entry visible - https://check-your-website.server-daten.de/?q=quasebuda.com#txt

Create one new entry, then recheck the domain.

If you want to create a certificate with the main domain name, the first blue marked part should have a value. Or two, if you want to create a wildcard.

The second blue marked -> value, if you want to create a certificate with the www-domain name.

1 Like

but I set up:

TXT _acme-challenge.quasebuda.com PUhUPUz... 600 seconds

but ins't propagating. Only is propagated with name ".quasebuda.com" in TXT.

That's the wrong name, that doesn't help.

Where do you create these entries? Perhaps it's the wrong place.

Share a screenshot of that menu.

Or is it possible that GoDaddy blocks these _acme-challenge entries?

Check the output of my own domain - https://check-your-website.server-daten.de/?q=server-daten.de#txt

That's the required output to confirm one wildcard *.server-daten.de (server-daten.de is confirmed via http-01 validation, so only one entry is required and created).


but I already tried configure the TXT with name “_acme-challenge.quasebuda.com” or “_acme-challenge” or “_acme-challenge.cam”, and none those worked. Only “.quasebuda.com” is worked.


is correct - https://check-your-website.server-daten.de/?q=cam.quasebuda.com#txt

But that's the domain name if you want a certificate with the domain name


I’m change to:


Use the online tool to check your domain and to see, if the TXT value is visible.

Ok, thanks.

I’ll wait until propagate, I think this will work, I was looking here:

but it never propagate, but as it showed me that with name “.cam” was ok, I think removing it will work, let’s wait to confirm.

That record exists now.

_acme-challenge.quasebuda.com. 600 IN   TXT     "PUhUPUz_Dqm6tmjpV_6jrzqwujHoXgzGopK85s8bXD0"
1 Like

Still not, look:

It still exists. That check is a few hours old.

Click the button "Check" to start a recheck of your domain. Your older result - 41 seconds required to query all informations.

1 Like

True, now is ok. Got it generation the certification now.

Thanks all.


But I’m receiving NET::ERR_CERT_COMMON_NAME_INVALID to the certification.

There is a gitlab certificate installed, so the domain name is wrong.

How do you install your certificate?

What’s the client you use?

I am using certbot, and then copying the full and private key to my gitlab page in the gitlab pages settings.

Gitlab had already set up a certificate for my domain, so I left theirs on, and now it works.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.