Trying to renew my cert but getting an error. Same error occurs if I try install instructions from beginging

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot renew

It produced this output: cannot stat /var/lib/snapd/seccomp/bpf/snap.certbot.certbot.bin: No such file or directory

My web server is (include version): nginx version: nginx/1.24.0

The operating system my web server runs on is (include version): Debian 6.5.13-1 (Trixie)

My hosting provider, if applicable, is: N/A

I can login to a root shell on my machine (yes or no, or I don't know): Yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): I get same error for this also "cannot stat /var/lib/snapd/seccomp/bpf/snap.certbot.certbot.bin: No such file or directory"

Looks like something has gone wrong with your snap or Certbot install.

What does this say

sudo snap list

You may need to reinstall Certbot. See


Hi, thanks for the reply. Below is the output of that command

Name                    Version    Rev    Tracking       Publisher     Notes
certbot                 2.7.4      3462   latest/stable  certbot-effâś“  classic
certbot-dns-cloudflare  2.7.4      3077   latest/stable  certbot-effâś“  -
core                    16-2.60.4  16202  latest/stable  canonicalâś“    core
core20                  20231123   2105   latest/stable  canonicalâś“    base
1 Like

Huh, looks like snapd is gone. That's in the path that could not be found /var/lib/snapd/.... Have you changed anything since your last renewal on Nov6?

If reinstalling doesn't fix it you may find help on a snap forum (link here) or the certbot github (here).

Here's my snap list. Notice the snapd component at the end

 sudo snap list
Name               Version          Rev    Tracking         Publisher      Notes
bare               1.0              5      latest/stable    canonicalâś“     base
certbot            2.8.0            3566   latest/stable    certbot-effâś“   classic
core               16-2.60.4        16202  latest/stable    canonicalâś“     core
core18             20231027         2812   latest/stable    canonicalâś“     base
core20             20231123         2105   latest/stable    canonicalâś“     base
core22             20231123         1033   latest/stable    canonicalâś“     base
lxd                5.0.2-838e1b2    24322  5.0/stable/…     canonical✓     -
snapd              2.61.1           20671  latest/stable    canonicalâś“     snapd

Nope haven't touched it since the day I installed it, not directly anyway unless something messed with it?

If I do sudo apt install snapd it says snapd is already the newest version (2.60.2-1+b2)

My /var/lib/snapd/seccomp/bpf path exists and there is files in it. Just not snap.certbot.certbot.bin...

snapd is the main daemon for snap. Don't know why it wouldn't show in your snap list and yet apt think it is installed.

Does the hello-world app install and run properly per snapcraft page:

If not you should visit the snap forum at the link I provided earlier.

Do other people mess with your system? Maybe talk with them


Sorry, missed all the updates you made to your prior post.

If the hellow-world app installed and ran you might try refreshing the certbot snap. See snap docs for all options

sudo snap help refresh


Yep hello-world installs fine and typing hello-world outputs "Hello World!"

Running the command sudo snap refresh certbot outputs

- Run configure hook of "certbot" snap if present (run hook "configure": cannot stat /var/lib/snapd/seccomp/bpf/snap.certbot.hook.configure.bin: No such file or directory)


Ok I removed certbot snap and certbot-dns-cloudflare by doing sudo snap remove certbot-dns-cloudflare and sudo snap remove certbot then running sudo snap install --classic certbot, sudo snap install certbot-dns-cloudflare and sudo snap set certbot trust-plugin-with-root=ok fixed the issue.

Thank you for the help :smiley:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.