Traefik SSL with certbot

Hello, I've had my setup running for 2 years. Now my domain provider started charging extra for DNS features which made me swap to Cloudflare. Then things broke and I forgot how I setup everything, hopefully I can get some help. Im running traefik for reverse proxys for my docker containers(homeassistant/plex/etc).
My first thought was that SSL was broken from the nameserver change, I could access but it complained about certificate somehow. I followed the basic guide and tried sudo certbot certonly --webroot first for without success. Port 443 from Traefik was in conflict at first. a SSL checker also says that there is "Certificate name mismatch", possibly a conflict with Traefik somehow? Sorry for this confusing report, I am very noob and I want to provide as much details as possible

My domain is:

I ran this command: certbot -d -d

It produced this output:
Error while running apache2ctl configtest.
Action 'configtest' failed.
The Apache error log may have more information.

AH00526: Syntax error on line 35 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
SSLCertificateFile: file '/etc/letsencrypt/live/' does not exist or is empty

My web server is (include version):

The operating system my web server runs on is (include version): Ubuntu 19.04

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 1.22.0

1 Like

Hi @sljdhl and welcome to the LE community forum :slight_smile:

Try that with sudo

And show the output of:
certbot certificates


ok so my huge mistake was to mispell the path *.domain.COM instead of SE. Embarassing. It was so long ago I set this up so I cant even remember anything. I dont even think im using SSL if traefik is setup to use TSL..
please close and delete this :expressionless:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.