Traefik 2.4 + LetsEncrypt - example fails to obtain ACME certificate for domain

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: docker compose:

image: "traefik:v2.4"
container_name: "traefik"
- "--log.level=DEBUG"
- "--api.insecure=true"
- "--providers.docker=true"
- "--providers.docker.exposedbydefault=false"
- "--entrypoints.web.address=:80"
- "--entrypoints.websecure.address=:443"
- "--certificatesresolvers.myresolver.acme.httpchallenge=true"
- "--certificatesresolvers.myresolver.acme.httpchallenge.entrypoint=web"
#- "--certificatesresolvers.myresolver.acme.caserver="
- ""
- ""
- "80:80"
- "443:443"
- "8080:8080"
- "./letsencrypt:/letsencrypt"
- "/var/run/docker.sock:/var/run/docker.sock:ro"

image: "traefik/whoami"
container_name: "simple-service"
- "traefik.enable=true"
- "traefik.http.routers.whoami.rule=Host("
- "traefik.http.routers.whoami.entrypoints=websecure"
- "traefik.http.routers.whoami.tls.certresolver=myresolver"

It produced this output:
traefik_2_4 | time="2021-06-02T04:17:57Z" level=error msg="Unable to obtain ACME certificate for domains "": unable to generate a certificate for the ddomains had a problem:\n[] acme: error: 403 :: urn:ietf:params:acme:error:unauthorized :: Invalid response from []: 404\n" providerName=myresolver.acme routerName=dashRouter@docker rule="Host("

My web server is (include version): traefik

The operating system my web server runs on is (include version): Ubuntu 18.04

My hosting provider, if applicable, is: running on AWS EC2

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.