This site can’t provide a secure connection ERR_SSL_PROTOCOL_ERROR


#1

I just created a ssl cert using https://www.sslforfree.com, and installled it , but it shows error as https://www.pccracker.com/ ERR_SSL_PROTOCOL_ERROR
I am on nginx server and shared hosting.
i Kknow this srror is common, but i am not able to solve it.


#2

Seems to be working for me. Which browser/OS/version are you using?

SSL Labs doesn’t report any issues with modern browsers.


#3

@pfg I am using Chrome Version 49.0.2623.112


#4

That should work fine. Can you try this with any other browser, and maybe from an additional device as well? Do you use any Anti-Virus software with a “web filter” for HTTPS connections? They have been known to break TLS connections oocasionally.


#5

@pfg Hello, it is working on firefox , BUT do not know why NOT on chrome and IE AND i have setup my antivirus to allow


#6

@pfg it’s a wordpress hosted site . if it helps you in finding the issue


#7

My best guess is that it’s some issue either on your device or the TLS configuration of your shared hosting provider is not compatible with Vista’s TLS stack (although SSL Labs indicates it is). In a typical shared hosting environment, that’s not something you can fix. I’d suspect a device issue, though. This is probably the part where I should ask whether you’ve tried turning it off and on again. :smile:

You can try https://www.howsmyssl.com/ which runs some check on your browser’s TLS support, maybe that’ll point you in the right direction.


#8

not able to follow you there :cold_sweat: and it is windows 7


#9

@pfg this i got on howsmyssl your SSL client is Probably Okay


#10

Sorry, haven’t looked at a Windows 7 desktop in quite a while. :smile:

This issue is specific to your PC/configuration. Maybe something is being cached, either in your browser or on some lower level. Restarting your PC and/or browser might solve the issue.

Could you add the full output of howsmyssl.com?


#11

Hello @theelitegrey,

I’m also getting the same error (Firefox, Chrome, curl, openssl…) but I’m a bit confused, SSL Labs reports that your ip is 45.34.121.170 but your dns are saying that your ips are 104.27.152.186 and 104.27.153.186 that seems ips for cloudflare

I think that you have messed you ns config between your hosting provider and cloudflare.

pccracker.com. 172800 IN NS ns21.hostitsmart.com.
pccracker.com. 172800 IN NS ns22.hostitsmart.com.
pccracker.com. 172800 IN NS donna.ns.cloudflare.com.
pccracker.com. 172800 IN NS lloyd.ns.cloudflare.com.

ns21 and ns22 doesn’t resolve from my site. I think you should double check your cloudflare config too.

Cheers,
sahsanu


#12

@pfg I moved to Win 8 and 10 but , they just were not in my favor, just not, no reason.:sunglasses:
HERE IS SCREENSHOT OF WHAT YOU NEEDED



#13

The TLS client looks fine. @sahsanu is right, there’s some DNS issue. Your site will probably work or not work depending on which name server happens to resolve the domain - I got lucky with the IP, you might have gotten an outdated one.


#14

Very well, thanks @sahsanu , you were right, i just resoved cloudflare dns from my hosting and it is now working. ,THANKS BROs and thanks to @pfg for providing such knowledge sources that i did not know off.
If there is any way i could repay then kindly let me know. Because as a programmer , i have been working over a week to solve it. Learning from it basically.I was so dumb :laughing:


#15

Glad you resolved the issue. I can confirm it is working fine from my side too :wink:


#16

@sahsanu . it is working here too thanks :innocent: and i do not know if it is a coincidence or my stars are aligned but many problems which used to exist are now dead. :kissing_smiling_eyes:


#17

You are still getting an F rating.

Try changing your config to something similar, I’m using apache, so here is my apache config.

SSLEngine on
SSLCertificateFile /home/user/ssl/0000_cert.pem
SSLCertificateChainFile /home/user/ssl/0000_chain.pem
SSLCertificateKeyFile /home/user/ssl/private.key
SSLProtocol +TLSv1 +TLSv1.1 +TLSv1.2
SSLHonorCipherOrder On
SSLCipherSuite EECDH+aRSA+AESGCM:EECDH+aRSA+SHA384:EECDH+aRSA+SHA256:EECDH+aRSA+RC4:EECDH:EDH+aRSA:!aNULL:!eNULL:!LOW:!MEDIUM:!SEED:!3DES:!CAMELLIA:!MD5:!EXP:!PSK:!SRP:!DSS:!RC4

This config will get you an A.


#18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.