There where to many requests


#1

I ran this command: certbot certonly XXX

It produced this output:
An unexpected error occurred:
There were too many requests of a given type :: Error creating new cert :: too many certificates already issued for: XX.io: see https://letsencrypt.org/docs/rate-limits/

The operating system my web server runs on is (include version): linux

I can login to a root shell on my machine (yes or no, or I don’t know): yes

Basically I don`t have any problems, I mess up little bit with code in cert requests went in loop, so I reached a limit, when I noticed this I fixed the issue, and now it works fine with --staging flag but when request for production fall on limits, is there a way how to drop limits and proceed with new certificate today? as now code works fine.


#2

No, there isn’t.

The one workaround available to you is to add another domain/subdomain to the certificate (even if you don’t need it), which will cause it to be counted against a different rate limit bucket.


#3

Is there a way to see my actual limits reach and when that domain will be unlocked?


#4

Not with any great accuracy. Certificate Transparency logs are the primary way, but they are often quite delayed.

https://tools.letsdebug.net/cert-search will report on rate limits, however certificates may be missing for a day or two sometimes.

You can also look up your certificates on https://transparencyreport.google.com/https/certificates which may be a bit more up-to-date , and count exactly 7 days after the earliest duplicate certificate from within the last 7 days.


#5

thanks for information


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.