The number of certificates issued by Let's Encrypt for your domain name has reached its limit. (Ref. 5017)

When accessing my server (Nimbustor AS54), I want to create a certificate using the Let's Encrpyt function. It worked the first time round but after a while, failed to renew upon expiry. I deleted the certificate and decided to try it again but I get the error above. I've waited weeks but still it won't renew so it's nothing to do with the limit.

My domain is:

Can you please check why I can't renew the certificate? Thanks.

Strange, now it works.......

@Steve6443 Welcome to the community.

Two things.

First, your Asus server is sending what looks like a root cert from Asus. This is not viable. You need to use a cert chain with your own name that matches your DNS and server.

openssl s_client -connect -servername

Certificate chain

Or, see:

Second, the error you saw about the name limit is likely related to your apex domain name That looks like a shared system and it could be limited by the 50 certs per registered domain per week limit . See:

You can usually look up how many names are used with but it is not right now showing the recent list using In fact, one of my attempts got an error from of "Unfortunately, searches that would produce many results may never succeed"

This rate limit is something to take up with reps


For example, they (but not an end user) could ask Let's Encrypt for a higher rate limit on the grounds that that domain is shared by a large number of different people. It is very common for Let's Encrypt to grant these requests and there's a whole process for it, but the process should be initiated by the domain registrant.


Domain is included in Public Suffix List so in this case the rate limits for should be the same as a normal domain.



Which Rate Limit is being hit?
I don't understand... |

1 Like

I don't know, we will need the actual output to know what's going on :wink:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.