The filename changes every request


Please fill out the fields below so we can help you better.

My domain is:,,

I ran this command:

Tried to renew a certificate using this site

It produced this output:

Domain "" challenge3 failed. Response from "" was: { "type": "http-01", "status": "invalid", "error": { "type": "urn:acme:error:connection", "detail": "Fetching Timeout", "status": 400 }, "uri": "", "token": "zdyKtAhW0mDH2VZ_plH8X3o1G96inVhDPxT08IYoDXI", "keyAuthorization": "zdyKtAhW0mDH2VZ_plH8X3o1G96inVhDPxT08IYoDXI.6QnZ6bBCNG1JpPO5nCjLV5kziWMqV-rM4OKSWxPWq9c", "validationRecord": [ { "url": "", "hostname": "", "port": "80", "addressesResolved": [ "" ], "addressUsed": "", "addressesTried": [] } ] }

the main domain is located in a different server than this domain (, this one is a cname

My web server is (include version):


The operating system my web server runs on is (include version):


I can login to a root shell on my machine (yes or no, or I don’t know):


I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


What it could be?


Bom dia @talski,

Indeed, the filename changes every request. When you use sslforfree, there should be a step at which they tell you the current filename, and you need to actually create that file on your web site at the specified location (in order to prove that you still control the domain name). When the certificate covers more than one domain name, you should be told about a challenge file to post at each domain name that the certificate should cover. You can then confirm to sslforfree that you’ve done so.


But now the main problem is this one, “connection Timeout” when letsencrypt tries to fetch the file on my server, but I’ve checked it and does not work

Domain “” challenge3 failed. Response from “” was: { “type”: “http-01”, “status”: “invalid”, “error”: { “type”: “urn:acme:error:connection”, “detail”: “Fetching Timeout”, “status”: 400 }, “uri”: “”, “token”: “J1iNPbvUBS7_M7hyu6plQdUZtwISodO87afuqd4TR08”, “keyAuthorization”: “J1iNPbvUBS7_M7hyu6plQdUZtwISodO87afuqd4TR08.6QnZ6bBCNG1JpPO5nCjLV5kziWMqV-rM4OKSWxPWq9c”, “validationRecord”: [ { “url”: “”, “hostname”: “”, “port”: “80”, “addressesResolved”: [ “” ], “addressUsed”: “”, “addressesTried”: [] } ] }


At the moment, the site doesn’t seem to be accessible at all for any purpose. Are you sure that you have a working web server up and running there?


Also ensure that it is accessible from outside your local network. It’s possible that whatever webserver running there is not exposed to the internet at large, only internally.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.