The client lacks sufficient authorization


#1

Hello,
I’m running Debian Jessie with apache, got an email today that my domains have been whitelisted (yay!) and after following the instructions I get this:

Failed authorization procedure. cloud.neso.ee (dvsni): unauthorized :: The client lacks sufficient authorization :: Correct zName not found for TLS SNI challenge

IMPORTANT NOTES:

  • The following ‘unauthorized’ errors were reported by the server:

Domains: cloud.neso.ee
Error: The client lacks sufficient authorization

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A record(s) for that domain
contain(s) the right IP address.

I have double checked the email for typos and there were none. Also the dns records are spot on.
I’m very exited about Let’s Encrypt, hopefully someone can help me get this thing working :blush:


#2

Got it working now! I have no idea what was wrong, but after 4th or 5th time of running the command

./letsencrypt-auto --agree-dev-preview --server https://acme-v01.api.letsencrypt.org/directory auth

it finally worked!
Cheers,
Neso


#3

I’ve ran into the same issue, and indeed it worked the on another try.


#4

I just want to leave a note here for those who may search for a solution.

I was seeing the message as @neso quoted, but in my case the cause was an Nginx configuration collision (see the issue #921 on github). The --text option passed to letsencrypt-auto helped me to see that Nginx config was incorrect and once I have fixed that, everything went smoothly.