The client lacks sufficient authorization :: Error creating new authz :: Validations for new domains are disabled in the V1 API

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:
Sudo certbot --nginx

It produced this output:
List of all domains to add the new certificate and I selected the appropriate number after that throwing this error:
An unexpected error occurred:
The client lacks sufficient authorization :: Error creating new authz :: Validations for new domains are disabled in the V1 API (End of Life Plan for ACMEv1)

What’s your certbot and OS version?

sudo certbot --version
cat /etc/os-release

certbot version : 0.22.2
OS:
NAME=“Ubuntu”
VERSION=“16.04.3 LTS (Xenial Xerus)”
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME=“Ubuntu 16.04.3 LTS”
VERSION_ID=“16.04”
HOME_URL=“http://www.ubuntu.com/
SUPPORT_URL=“http://help.ubuntu.com/
BUG_REPORT_URL=“http://bugs.launchpad.net/ubuntu/
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial

Also include more detail about the failure:

Was there any code or number shown?

That needs some updating.

Yep, exactly.

Follow along these instructions to upgrade for your OS: https://certbot.eff.org/#ubuntuxenial-nginx

This will automatically upgrade you to ACME v2 and you can be on your way.

1 Like

The error clearly states he’s connecting to the version 1 API, which is disabled.

1 Like

Thank you,
Now it is working