The certificate authority failed to verify the temporary nginx configuration changes. Ensure the listed domains point to this nginx server and that it is accessible from the internet

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. |, so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command: sudo certbot --nginx -d -d

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Requesting a certificate for and

Certbot failed to authenticate some domains (authenticator: nginx). The Certificate Authority reported these problems:
  Type:   dns
  Detail: no valid A records found for; no valid AAAA records found for

Hint: The Certificate Authority failed to verify the temporary nginx configuration changes made by Certbot. Ensure the listed domains point to this nginx sever and that it is accessible from the internet.

My web server is (include version): nginx 1.24.0

The operating system my web server runs on is (include version): ubuntu

My hosting provider, if applicable, is: Digital ocean

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): digital ocean / terminal

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): 2.1.0

I am able to access the website via visiting the domain It's showing the Godot message that I expect it to show at the moment.

root@galaxy-game-server:/etc/nginx/sites-enabled# curl -4

matches my A


Hi @wadlo, and welcome to the LE community forum :slight_smile:

I suppose that was a temporary error.
I'd try it again.
But you should be doing these types of tests [yes, this is now testing] on the staging environment.

sudo certbot --nginx -d --dry-run
sudo certbot --nginx -d --dry-run

See if they both pass individually.

1 Like

Figured out I need both a www hostname and a @. For those looking at this in the future.

1 Like

So, you had no A record for LE to find - LOL


That could do with an update.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.