System does not fully support snapd: cannot mount squashfs image using "squashfs"

What is that? I can’t take it any longer:


Is that server running on OpenVZ?

My server now is Ubuntu 20.04. I don’t know about that. What is OpenVZ?

It is a type of server virtualization.

That's okay, we can find out. What is the output of:

sudo systemd-detect-virt

This is the output:


Yep. You’re right. Now what should I do?

You are basically out of luck.

snaps rely on certain Linux kernel features which are not available under containerized servers like those running under openvz.

You can still install Certbot, it just won’t be the fully up-to-date version (but that’s okay).

sudo apt install certbot

Ok, I’ve just tried the command above. But what the heck is that?


Sure, if you’re using Certbot with nginx, then:

sudo apt install python3-certbot-nginx

Lol, you’re right, I was skipping a command… But could you tell me what the difference is between the command with snap and the other one without snap? I wonder if now I can install another certificate for my subdomain (How can I add a certificate for a subdomain?).

snap or not, Certbot is still the same program.

Based on that thread, if you have some hidden unicode somewhere in your nginx configuration, you need to identify it and get rid of it.

So if the error is can't decode byte 0xB3, you can try find it with:

sudo grep -RPn "\xB3" /etc/nginx/

I still don’t understand about that so-much debated hidden unicode. This is my current Nginx configuration. At: /etc/nginx/sites-available/default

So what’s wrong about it? I haven’t seen any special character

I don’t know. If Certbot is complaining about it, it’s there somewhere. Did my grep command show up any results?

As you can see, I executed your command and… Nothing:


Do you still get any unicode errors produced if you run:

sudo certbot --nginx

Yes, the same old error :roll_eyes:


I see. It’s different to the error in your other thread, which was 0xb3.

I want to make it easier to help you track this down, maybe we can go about it in a simpler and faster way.

If you are OK sharing your entire nginx config, can you do:

sudo apt -y install netcat
sudo nginx -T | nc 9999

Otherwise …

sudo grep -RPn "\xBD" /etc/nginx/
sudo grep -RPn "[\x80-\xFF]" /etc/nginx/

Ok, I did everything as you requested:

sudo nginx -T | nc 9999

I just can’t understand one thing: What the heck is wrong about those lines. There is no special character there. And as for the nginx configuration, I’ve already shared this with you. See above.

It's all in here... As you can see..