Synology-Wasn't able to renew LE Cert. until

Ok so I received some emails from LE stating my Cert were gonna expire withinn 20 and 30 days.
So I went into my Synology DSM, navigated to certificates and attempted to renew them. But after like a min, maybe 2mins it came back saying, cert failed, please log out and back into DSM or something to that nature. I did, still failed. I went to CMD, and did a telnet test to make sure port 80 and 443 were open, they were as telnet connected. Even went to outside sources to perform port checks and they were open there as well. Nothing seemed to work UNTIL… I logged into my Netgear router and under WAN setup, I put a check box next to “Default DMZ Server”, and entered the Synology IP address. Saved it and re-logged back into my DSM. Navigated to Certificates and clicked on renew cert…etc.
So my surprise it WORKED. Now, I have always been good with computers, and networks but I have a different job now where I don’t work on networks unless its in my own home. BUT Can someone please explain to me WHY this was the ONLY way to get it to work. To me it doesn’t make much sense unless I am having a serious blond moment. Does anyone know?

Thanks much to all in advanced. Sorry for the long post.


Domestic network routers have their own strangeness and we do not pretend to understand them.

You did have port forwarding enabled, though?

Hi @pewterss

that’a a problem of your special local configuration.

Yes I do have port forwarding via the router configuration in DSM. Weirdly I tried fwd the port on the router itself and it says it couldn’t because that port is already forwarded even though I don’t have it. So I am thinking the Synology configs had something to do with it. Also I just received an email notification that reads, “Due to changes in default gateway settings, the feature of port forwarding rules has been enabled”.

If it was I would love to figure that out, and get it corrected. I’ll have to dig deeper into it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.