Sudden Error using Certbot NET::ERR_CERT_AUTHORITY_INVALID

I have been installing SSL certificates using cerbot for years now using the same command without issues, lately - I get this problem - Certificate not valid. I have tried different Ubuntu versions, I cannot figure out what is causing it.

My domain is:

I ran this command: sudo certbot --nginx -d

It produced this output: The certificate was installed as usual, I have ran this command many times in the past with other domains without an issue

My web server is (include version): Nginx

The operating system my web server runs on is (include version): Ubuntu 16.04 LTS Xenial

I can login to a root shell on my machine (yes or no, or I don't know): Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot): certbot 0.31.0

1 Like

Hi @tatiblockchain

there is no problem visible - see

The certificate is new
expires in 90 days - 1 entry

no chain problems.

Only "problem": You have defined the www subdomain in your DNS.

But your domain has only the non-www domain name. So the www domain name has the wrong certificate, that connection is insecure.

But normally, www isn't used if it is a subdomain.

  • Remove the www CNAME (or)
  • Create a certificate with both domain names
1 Like

Thank you, i removed the www DNS record and it works perfectly.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.