Successful Certificate Creation, Still Don't Have Secured on the Website

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
www.graysquid.net

I ran this command:
sudo certbot --nginx -d www.graysquid.net

It produced this output:

root@grayman500:~# sudo certbot --nginx -d www.graysquid.net
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator nginx, Installer nginx
Cert not yet due for renewal

You have an existing certificate that has exactly the same domains or certificate name you requested and isn’t close to expiry.
(ref: /etc/letsencrypt/renewal/www.graysquid.net.conf)

What would you like to do?


1: Attempt to reinstall this existing certificate
2: Renew & replace the cert (limit ~5 per 7 days)


Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 1
Keeping the existing certificate
Deploying Certificate to VirtualHost /etc/nginx/sites-enabled/default

Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.


1: No redirect - Make no further changes to the webserver configuration.
2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
new sites, or if you’re confident your site works on HTTPS. You can undo this
change by editing your web server’s configuration.


Select the appropriate number [1-2] then [enter] (press ‘c’ to cancel): 2
Redirecting all traffic on port 80 to ssl in /etc/nginx/sites-enabled/default


Congratulations! You have successfully enabled https://www.graysquid.net

You should test your configuration at:
https://www.ssllabs.com/ssltest/analyze.html?d=www.graysquid.net


IMPORTANT NOTES:

  • Congratulations! Your certificate and chain have been saved at:
    /etc/letsencrypt/live/www.graysquid.net/fullchain.pem
    Your key file has been saved at:
    /etc/letsencrypt/live/www.graysquid.net/privkey.pem
    Your cert will expire on 2020-08-07. To obtain a new or tweaked
    version of this certificate in the future, simply run certbot again
    with the “certonly” option. To non-interactively renew all of
    your certificates, run “certbot renew”

  • If you like Certbot, please consider supporting our work by:

    Donating to ISRG / Let’s Encrypt: https://letsencrypt.org/donate
    Donating to EFF: https://eff.org/donate-le

My web server is (include version):
Nginx (

The operating system my web server runs on is (include version):
Raspbian (Latest Version)

My hosting provider, if applicable, is:
Nginx

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
Yes

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
0.31.0

What error message are you getting?

For me, connecting to your website over HTTPS times out.

(HTTP works.)

Are you sure your firewall and port forwarding settings for port 443 are correct?

Could Spectrum be blocking it?

2 Likes

I have the same issue sometimes. I disabled my home network firewall on my personal computer. That let’s me view the website. But if I don’t disable it, it does the same thing for me… I’m not sure what to do.

The server is on a Raspberry Pi 4 running Nginx, could it be firewall settings on that? Or does the Google not like it because it’s not secure?

I just enabled PHP, not sure if that will help, but maybe.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.