Sub-domains with port exposed doesn't work with ssl


#1

I have created a single certificate for main domain and sub-domain. The sub-domain runs on port 4200.
But ssl doesn’t work for the sub-domain with the port exposed.


#2

Hi @sandeep

if you have the certificate created and if the certificate has the required two names, then the port shouldn’t be the problem.

But without your domain name and your exact command (only certificate, certificate + installation) it’s impossible to find a solution.


#3

Hi,

It gives me below error for sub-domains.
“it is possible that this site uses an unsupported protocol or cipher suite such as RC4”


#4

Please share your domain name.

Certificates are logged, so they are public.


#5

My domain name is mockrabbit.com.
And the issue i’m facing is for the sub-domain dev.mockrabbit.com. When i access https://dev.mockrabbit.com it doesn’t give me any error, but when i try to access with the port https://dev.mockrabbit.com:4205 , it throws me error.


#6

Your https://dev.mockrabbit.com:4205 sends a SSL_ERROR_RX_RECORD_TOO_LONG error.

That means, that this port sends too much data. This is often the result, that there is http content sent.

So:

http://dev.mockrabbit.com:4205/

Yep, there is a page and a redirect to http://dev.mockrabbit.com:4205/login with a login.

So you must configure your 4205 as https - port, not http - port.


#7

Now, i have removed the redirect and it works fine.
Another thing i’m looking it is to make both http and https work in the sub-domain. What is the setting i need to setup in my virtual host file.


#8

What does this mean?


#9

Hi,

I want the sub-domain to work with http and https too. Currently, it works either with https or http.


#10

If you have one port 4205, you can use this port with http or with https - not with both.

Now this port works with http - http://dev.mockrabbit.com:4205/login

If you want an additional https, then use the next port 4206.

But I would remove the http - login, because login data should always secured.

And the browser shows a bad warning, if there is a login via http.

com


#11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.