SSL keeps failing both to renew and also to request certificate PLEASE HELP

I,m wrecking my brains out on this - just can't seem to get a certificate even renewal is failing - I've tried both Please bear with me on this as I'm not very technical - Hope someone out there can help

My domain is: priyaexclusives.com

I ran this command: Lets Encrypt Request Certificate

It produced this output:
Requesting a certificate for priyaexclusives.com, www.priyaexclusives.com from Let's Encrypt ..
.. request failed : Web-based validation failed :

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
Starting new HTTPS connection (1): acme-v02.api.letsencrypt.org
Renewing an existing certificate for priyaexclusives.com and www.priyaexclusives.com
Reusing existing private key from /etc/letsencrypt/live/priyaexclusives.com/privkey.pem.
Performing the following challenges:
http-01 challenge for priyaexclusives.com
http-01 challenge for www.priyaexclusives.com
Using the webroot path /home/priyaexc/public_html for all unmatched domains.
Waiting for verification...
Challenge failed for domain priyaexclusives.com
Challenge failed for domain www.priyaexclusives.com
http-01 challenge for priyaexclusives.com
http-01 challenge for www.priyaexclusives.com
Cleaning up challenges
Some challenges have failed.
IMPORTANT NOTES:

My web server is (include version): Webmin Version 2.101 with Virtualmin Version 7.7

The operating system my web server runs on is (include version): CentOS Linux 7.9.2009

My hosting provider, if applicable, is: Contabo

I can login to a root shell on my machine (yes or no, or I don't know): I'm not a pro so don't use this (avoid if I can)

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): Webmin root user

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

Thanks

Hello @Pappaji,

What ACME Client and Version are you using?

I also note:

Is that the correct location?

I also think your Server is Apache.

$ curl -Ii http://priyaexclusives.com/.well-known/acme-challenge/sometestfile
HTTP/1.1 404 Not Found
Date: Fri, 08 Sep 2023 17:49:18 GMT
Server: Apache
Content-Type: text/html; charset=iso-8859-1
1 Like

Hi Bruce5051

I'm using Lets Encypt and yes the server is Apache
here are some other details if it helps

SYSTEM INFORMATION
OS type and version CentOS Linux 7.9.2009
Webmin version 2.101
Usermin version 2.001
Virtualmin version 7.7
Theme version 21.04
Package updates All installed packages are up to date

You might find more help on the VirtualMin community. The 404 error (http Not Found) usually means a mismatch between how VirtualMin has configured Certbot (behind the scenes) and how Apache is configured.

I think it will be some quirk with the VirtualMin config and more experts for that are:

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.