SSL installed , Port 443 Working but not serving https


#1

Hi, Since last 2 days I am trying to solve this issue. Certificates are installed but not replicating on server.
I have enabled mod_ssl , installed openssl, checked for all the configurations. Followed all the threads with the same issues. Created all the changes but its not helping.
Please see the below links for the configuration files and suggest any change you believe I should do.

Apache2.conf (Text File)

000-default.conf (Text File)

000-default-le-ssl.conf (Text File)

Ports.conf (Text File)

httpd.conf (Text File)

default-ssl.conf (Text file)


#2

Hi @Danish22,

The first thing you should do is to comment out one of the IfModule in your ports.conf. You have two entries, mod_ssl.c and ssl_module and both are the same module so I really doubt your apache can start because it will try to bind to and address on port 443 twice:

Current ports.conf:

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80
<IfModule mod_ssl.c>
         Listen 443 
  
</IfModule>
<IfModule ssl_module>
	Listen 443
</IfModule>

<IfModule mod_gnutls.c>
	Listen 443
</IfModule> 

Modified ports.conf:

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80
<IfModule mod_ssl.c>
         Listen 443 
</IfModule>

#<IfModule ssl_module>
#	Listen 443
#</IfModule>

<IfModule mod_gnutls.c>
	Listen 443
</IfModule> 

Also, in your apache2.conf file you have commented the Include to load your conf files from sites-enabled:

Current apache2.conf:

# Include the virtual host configurations:
#IncludeOptional sites-enabled/*.conf

Modified apache2.conf:

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

Perform these changes, restart your apache and try again.

Cheers,
sahsanu


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.