SSL certificate problem after quit DST Root CA X3

Looking for the solution to the issue of the expiration of the DST Root CA X3 certificate we found this thread

following the steps to remove the expired certificate, now when we try to make a request by curl we get the SSL certificate problem: unable to get local issuer certificate error

How can we solve this?

It is worth mentioning that our certificates are generated with Certbot 1.11.0 and our server is an Amazon Linux 2 with OpenSSL 1.0.2k-fips and I can login to a root shell on my machine and the domain is

@edorantes Welcome to the LE community

What curl command are you trying? I can curl to your server with both http and https.

1 Like

Try following this document: Correct expired Let’s Encrypt certificate on EC2 instances

We are doing the CURL from PHP with Wordpress to an api that is https

We tried this solution by regenerating the certificates with Certbot and it seems that it no longer renews our certificates with the expired certificate, but it keeps giving us the same error, apparently it is a wordpress theme that is the platform we use where it is generating the error, doing a debugging from the code we realized that wordpress has embedded some certificates we have replaced them and we no longer have that error


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.