Ssl cert keeps failling with No-IP DDNS


#1

is there a know issue or is No-IP ddns (sub)domain name keeps on falling at the acme challenge step?
I have nginx on my raspberry pi, no firewall - nothing configured that may block this challenge verification.


#2

Can you provide more information?

It should work. There might be rate limit issues sometimes.

If there’s a general problem, I think you’re the first person to discover it.


Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:

I ran this command:

It produced this output:

My web server is (include version):

The operating system my web server runs on is (include version):

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):


#3

I have tried on clean (sever) installation - turned off nginx service, tried the --certonly option + standalone, no luck. Tried it with nexcloudPi image which used to work with no issue but now it failed.

My domain is: service2.ddns.net

I ran this command:
sudo certbot --authenticator webroot --installer nginx
sudo certbot certonly --authenticator standalone --pre-hook "nginx -s stop" --post-hook "nginx"

It produced this output:
the failing result of unable to retried the challenge key
My web server is (include version): nginx 1.12

The operating system my web server runs on is (include version): raspbian strech latest release.

My hosting provider, if applicable, is: no-ip ddns

I can login to a root shell on my machine (yes or no, or I don’t know): YES FULL CONTROL of my raspberry pi.
I’m using a control panel to manage my site (no, or provide the name and version of the control panel): n/a


#4

The idea of that question is to show the full command output. Just telling us that you got output saying it failed is completely useless to anyone trying to help you.


#5

For what it’s worth, that may not start Nginx how your operating system expects. Something like “service nginx start” or “systemctl start nginx” would probably be better.

(But it also should be possible to do this without stopping and starting Nginx.)


#6

this isn’t a problem, even nginx -s stop or sudo systemctl stop nginx still no luck.


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.