Something went wrong. (0 , s.useTranslate) is not a function

Since yesterday we have a problem on reissue certificate on Plesk:

  1. We Go to Domain
  2. Click Reissue Certificate
  3. Install a free basic certificate provided by Let's Encrypt - Click Install

Shows ERROR:

Something went wrong.

(0 , s.useTranslate) is not a function

It's a problem on all domains.

Can you help us? Thank you

Is your Plesk provided by your hosting provider? Or did you install Plesk yourself on e.g. a virtual server?

Because this really looks like an issue with Plesk and not with Let's Encrypt.

4 Likes

Yes, by OVH.
Plesk says it's OVH that has to help.
OVH says it has nothing to do with it.

I also think it's a Plesk error because it happened since yesterday. But I don't see anyone talking about it and we haven't made any changes to the server these days.

That's very unfortunate.. You're a customer of OVH, so I'd think it really is OVH that needs to do something about this.

Otherwise "downvote" with your money by taking your website(s) to a different hosting company.

In any case I'm afraid this is not something Let's Encrypt can fix, nor we as a Community I think.

5 Likes

I found it.
I changed this information, but it doesn't work. Someone help please?

[ext-letsencrypt]
showInterface = true

Plesk Obsidian Web Pro Edition
Version 18.0.28 Update #3
OS Debian 8.11


Let's Encrypt Extension​

Changes​

3.0.0 (15 March 2022)​

  • Converted the extension into the SSL It! plugin. In Plesk Obsidian 18.0.22 and later, it is no longer possible to issue and manage Let's Encrypt certificates without the SSL It! extension.
    Note: The upgrade from the Let's Encrypt extension 2.x to 3.0.0 automatically installs SSL It! (if you do not have it installed yet).

2.15.0 (15 February 2022)​

  • [!] According to the deprecation plan, we hide the Let's Encrypt interface elements. This change was announced in the Let's Encrypt 2.14 release. For now, you can bring back the Let's Encrypt interface elements by adding the following lines to the panel.ini file:
    [ext-letsencrypt]
    showInterface = true

On March 15, 2022 (Let's Encrypt release 3.0.0), we completely convert the extension into the SSL It! plugin. It will no longer be possible to issue and manage Let's Encrypt certificates without the SSL It! extension in Plesk Obsidian 18.0.22 and later.
If your Plesk does not have the SSL It! extension installed, the Let's Encrypt release 3.0.0 will automatically install it.

That's to be expected. That panel.ini trick was for the 2.15.0 release of the plugin. However, in the 3.0.0-release:

And your Plesk version is:

Conclusion: you need to use the "SSL It!" extension, not the one you're currently using apparently.

3 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.