Someone on my team genius-ly deleted /etc/letsencrypt

My domain is:

I ran this command: I have tried to reinstall cert bot sudo apt-get remove python-certbot-apache and then reinstalled to no avail.

It produced this output: Whenever I reinstall, now that /etc/letsencrypt/ was deleted, we get the following error when trying to install a certificate:

Error while running apache2ctl configtest.
Action 'configtest' failed.
The Apache error log may have more information.

AH00526: Syntax error on line 130 of /etc/apache2/sites-enabled/default-ssl.conf:
SSLCertificateFile: file '/etc/letsencrypt/live/' does not exist or is empty

My hosting provider, if applicable, is: DigitalOcean

I can login to a root shell on my machine (yes or no, or I don’t know): Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): No

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Hi @mnewber1

your config file should have the path and file name of a self signed certificate.

Use this instead, so Apache2ctl should work.

Or disable the default-ssl.conf ( /sites-enabled).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.