Some challenges have failed

hi im trying to figure it out what went wrong tried to follow some solutions here but still unable to rectfy this problem.

My domain is:

I ran this command:

certonly --webroot -w C:\Users\Administrator\Desktop\Project-daddict -d

It produced this output:

Certbot failed to authenticate some domains (authenticator: webroot). The Certificate Authority reported these problems:
Type: unauthorized
Detail: Invalid response from 40

My web server is (include version):

windows server 2019 using IIS

If you need a cert for an IIS website it's easier to use Certify The Web or win-acme (or Posh-acme if you prefer scripting). Certbot doesn't have native support for IIS and no longer officially supports Windows.

To get this cert request to work though, you would need to configure IIS to serve extension less text files (the challenge response files are text files with no .txt extension), once you had your cert you would need to convert it to PFX and store it in the machine certificate store, then update your IIS https binding.


@webprofusion first of all happy new year to you,

second is thankyou for your quick response,

And lastly your the men bro !! win-acme solve my mental health ,

That why experts always knows best!!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.