Some challenges have failed when generating certificate

My domain is: help.revonecompanies.com

I ran this command: certbot -v certonly --webroot

It produced this output:

My web server is (include version): Microsoft IIS 10.0

The operating system my web server runs on is (include version): Windows Server 2022 (AWS Instance)

I can login to a root shell on my machine (yes or no, or I don't know): yes

I originally got an SSL cert from DirectNic to put into my web server for https traffic but that was having some issues, so I tried to go this route. The SSL cert is still attached to that domain on my webserver currently, so maybe there is an issue there? My website works on http, but the connection resets when I try to access it by https

Hi @billy.cox, and welcome to the LE community forum :slight_smile:

As much as I do like certbot, I think there are better native ACME clients for Windows.

That said, I don't see where you entered the webroot for that FQDN.
[without which, certbot won't be able to know where to place the challenge file]
So...
You should be more specific in the request.
More like:
certbot certonly --webroot -w "c:\web\site\path" -d help.revonecompanies.com

4 Likes

It's on the 9th line of the screenshot.

5 Likes

@Osiris, Good eyes!
[small pic print]

So, then it must be the wrong path.

I'd test that out by placing a challenge looking test file there [and a simple hello.txt file too]
A file with only letters, numbers, and hyphens [not at the ends?] and without any dots.
Then see if you can reach those files with:
http://help.revonecompanies.com/file-name
and
http://help.revonecompanies.com/hello.txt

4 Likes

I agree with Rudy there are better Windows ACME clients especially when using IIS as your server. I think the most popular for that is the gui product Certify The Web

5 Likes

Thanks Mike,

I will try that ACME client instead.

3 Likes