[SOLVED] (tls-sni-01): Error getting validation data

Hi all,

I’m trying to enable HTTPS initially with LetsEncrypt and the Nginx web server running on my JiffyBox but get the error “tsdh.org (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Error getting validation data”.

My domain is: tsdh.org

I ran this command: sudo certbot --nginx

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log

Which names would you like to activate HTTPS for?
1: tsdh.org
2: rotkap.tsdh.org
3: www.tsdh.org
Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel): 1
Obtaining a new certificate
Performing the following challenges:
tls-sni-01 challenge for tsdh.org
2017/08/27 10:10:01 [notice] 4027#4027: signal process started
Waiting for verification…
Cleaning up challenges
2017/08/27 10:10:05 [notice] 4029#4029: signal process started
Failed authorization procedure. tsdh.org (tls-sni-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Error getting validation data


  • The following errors were reported by the server:

    Domain: tsdh.org
    Type: connection
    Detail: Error getting validation data

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

My web server is (include version): nginx-1.13.4

The operating system my web server runs on is (include version): Arch Linux (up to date)

My hosting provider, if applicable, is: domainfactory, the server is a JiffyBox

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

It looks like port 443 on your IPv4 address is OpenSSH. Not Nginx.

You could use DNS-01 or HTTP-01 validation, but TLS-SNI-01 (as the nginx plugin does) won’t be possible without the right server on port 443.

Additionally, the AAAA records are for an fe80::/16 IP address, which are only valid on your LAN. You should probably switch the records to a global address, or the remove them.

1 Like

Oh, gosh! This is so embarrassing. Some time ago I’ve setup port 443 for SSH because my employer blocked port 21 and I wanted to reach the machine from work… Thanks for the reminder! :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.