[Solved] Installer Issues


#1

I was reading the guide here: https://community.letsencrypt.org/t/quick-start-guide/1631

and was unable to follow the steps listed. Below is the output from terminal. Is there an error log found somewhere that I can post?

OS: Debian 7.9 wheezy
Server version: Apache/2.2.22

Requesting root privileges to run with virtualenv: /root/.local/share/letsencrypt/bin/letsencrypt
No installers seem to be present and working on your system; fix that or try running letsencrypt with the "certonly" command
root@root:~/letsencrypt# ./letsencrypt-auto --apache
Updating letsencrypt and virtual environment dependencies......
Requesting root privileges to run with virtualenv: /root/.local/share/letsencrypt/bin/letsencrypt --apache
The apache plugin is not working; there may be problems with your existing configuration.
The error was: PluginError('Unable to parse runtime variables',)

#2

Sounds like this known issue:

You could try running from master as described here. If the error still persists, you will have to wait for a more comprehensive fix. You could use webroot mode in the meantime, and manually configure your apache for SSL.


#3

Thanks that worked, it seems to fail if your virtualhost line is like the following.

Changing the asterisk to the domain name will fix it, but then when you restart apache it will complain that it’s incorrect unless you change it to an ip or back to an asterisk.