(SOLVED) Illegal Instruction when running CERTBOT

My domain is:goosegate.co.uk

I ran this command: certbot --apache

It produced this output: illegal instruction

My web server is (include version): Apache/2.4.10 (Raspbian) and Python 2.7.9

The operating system my web server runs on is (include version): Debian (raspbian) Jessie

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I have previously used CERTBOT on another Debian (Raspbian) Jessie system without any issues, This is a newly created system and I was following the commands at https://certbot.eff.org/#debianjessie-apache
and get
xxx@goosegate:~ $ certbot --apache
Illegal instruction
xxx@goosegate:~ $

Any ideas pls?

Hi @philpugh,

I remember a previous related thread about this:

I went through a lot of debugging with the other user but I originally didn't realize what @Patches ended up telling us, which was that there are two versions of the ARM architecture that Raspbian doesn't distinguish between properly. Thus, it's willing to install library packages that aren't applicable to the actual ARM hardware that you have on your Pi. That leads to these illegal instruction errors.

I'm not sure that I understood in the other thread what people are recommended to do about this situation.

@philpugh You are using a Raspberry Pi 1, not the later models, correct? Debian Backports isn’t compatible with the ARMv6 processor used in the Raspberry Pi 1 and this leads to illegal instruction errors. (Officially, it isn’t compatible with the later versions either, because it is built against Debian proper and not the Raspbian rebuild, but it typically works fine.)

You could use certbot-auto, which has no dependencies on backports for Jessie and should be fine. You must remove all packages you installed from backports first, however, as even one dependency would get picked up and cause crashes.

Or you could upgrade to Raspbian Stretch, where certbot is included in the release and would be built properly for the Pi 1.


Thanks all. I was using a Pi Zero - took the SD card out and popped it into a Pi 2 and everything is OK!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.